Avalara AvaTax Service Degradation

Incident Report for Avalara

Resolved

The Avalara AvaTax service has been fully restored.
Posted Apr 15, 2025 - 06:28 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2025 - 06:20 PDT

Investigating

Avalara AvaTax customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Apr 15, 2025 - 06:02 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service), Avalara Cross Border (Cross Border Quoting, Cross Border Restrictions), and Avalara Returns (Returns Console).