Avalara AvaTax Tax Calculation Service Item Update Delays

Incident Report for Avalara

Resolved

The Avalara AvaTax Tax Calculation Service has been fully restored.
Posted May 06, 2026 - 12:31 PDT

Identified

Avalara AvaTax Tax Calculation Service customers may be experiencing delays seeing updates to newly created or updated Items. There is no immediate impact to Tax Calculation calls. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted May 06, 2026 - 10:22 PDT

Investigating

Avalara AvaTax Tax Calculation Service customers may be experiencing delays seeing updates to newly created or updated Items. There is no immediate impact to Tax Calculation calls. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted May 02, 2026 - 03:30 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service).