Business Licenses Service Degradation

Incident Report for Avalara

Resolved

The Business Licenses service has been fully restored.
Posted Jun 23, 2025 - 13:08 PDT

Investigating

Business Licenses customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jun 23, 2025 - 12:16 PDT
This incident affected: Avalara Business Licenses (Avalara License Management).