Avalara Exemption Certificate Management - backlog of tasks are causing a delay in processing

Incident Report for Avalara

Resolved

The Avalara Exemption Certificate Management service has been fully restored.
Posted Apr 02, 2026 - 00:08 PDT

Monitoring

Avalara Exemption Certificate Management team has addressed the backlog of tasks that caused delay in processing and continues to monitor service to ensure the return of full service for all customers.
Posted Apr 02, 2026 - 00:05 PDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2026 - 08:49 PDT
This incident affected: Avalara Exemption Certificate Management (Background Tasks).