PRD Business licenses site is down

Incident Report for Avalara

Resolved

The Business Licenses service has been fully restored.
Posted Jun 04, 2025 - 21:19 PDT

Investigating

PRD Business licenses site is down from 8:09 PM PST and Teams are connected on an incident zoom to investigate and fix the issue.
Posted Jun 04, 2025 - 20:09 PDT
This incident affected: Avalara Business Licenses (Business Licenses Customer & Partner Sales & Support Portal).