Avalara AvaTax Service Degradation

Incident Report for Avalara

Resolved

The Avalara AvaTax service was fully restored as of 6:48 PM PDT
Posted Jun 17, 2025 - 19:33 PDT

Monitoring

The response team has addressed the issue impacting AvaTax customers and continues to monitor service to ensure the return of full service for all customers.
Posted Jun 17, 2025 - 19:29 PDT

Investigating

Avalara AvaTax customers may be experiencing degraded service levels starting at 6:20 PM PDT. Our response team is actively investigating the issue. This page will be updated with the latest information as it becomes available
Posted Jun 17, 2025 - 19:27 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service, Restv2).