Avalara Cross Border Service Degradation

Incident Report for Avalara

Resolved

The Avalara Cross Border service has been fully restored.
Posted Apr 14, 2025 - 11:54 PDT

Monitoring

The response team has addressed the issue impacting Avalara Cross Border and continues to monitor service to ensure the return of full service for all customers.
Posted Apr 14, 2025 - 10:35 PDT
This incident affected: Avalara Cross Border (Cross Border Quoting, Cross Border Restrictions).