The Business Licenses service has been fully restored.
Posted Oct 20, 2025 - 15:37 PDT
Monitoring
The response team has addressed the issue impacting Business Licenses and continues to monitor service to ensure the return of full service for all customers.
Posted Oct 20, 2025 - 12:09 PDT
Update
Business Licenses customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Oct 20, 2025 - 11:29 PDT
Identified
Business Licenses customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Oct 20, 2025 - 09:48 PDT
This incident affected: Avalara Business Licenses (Avalara License Management, File Assist Questionnaire, Filing Assist Manager, Business Licenses Customer & Partner Sales & Support Portal).