AvaTax Service Degradation
Incident Report for Avalara
Resolved
The Avalara AvaTax service has been fully restored.
Posted Jan 28, 2025 - 22:42 PST
Investigating
AvaTax customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jan 28, 2025 - 22:11 PST
This incident affected: Avalara AvaTax (Tax Calculation Service).