AvaTax UI Service Degradation

Incident Report for Avalara

Resolved

This incident has been resolved.
Posted May 08, 2025 - 09:00 PDT

Investigating

AvaTax UI customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted May 08, 2025 - 08:38 PDT
This incident affected: Avalara AvaTax (AvaTax UI, Restv2).