Avalara Business License Service Degradation

Incident Report for Avalara

Resolved

The Avalara Business Licenses service has been fully restored.
Posted Oct 20, 2025 - 02:38 PDT

Investigating

Avalara Business License Service customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Oct 20, 2025 - 01:52 PDT
This incident affected: Avalara Business Licenses (Avalara License Management, Avalara License Guidance, File Assist Questionnaire, Filing Assist Manager, Business Licenses Customer & Partner Sales & Support Portal, Main License Repository (MLR) API, NRL MCP Server).