AvaTax and MyLodge Phone Support Service Degradation

Incident Report for Avalara

Resolved

The third-party vendor supporting our customer support phone system has mitigated the impact, and contacts are now routing as expected.
Posted Jun 02, 2026 - 21:37 PDT

Identified

A third-party vendor supporting our customer support phone system is currently experiencing an issue.
As a result, customers contacting support by phone may encounter increased hold times. There is no impact to Avalara product availability or functionality.
We are monitoring the vendor's recovery efforts and will provide updates as they become available.
Posted Jun 02, 2026 - 08:30 PDT
This incident affected: Avalara Toll-Free Phone Numbers (Avalara Main Number, Avalara Enterprise Support Number, MyLodge Support Number).