Returns Console Service Degradation
Incident Report for Avalara
Resolved
Returns Console service has been fully restored.
Posted Mar 23, 2024 - 18:34 PDT
Monitoring
The response team has addressed the issue impacting Returns Console and continues to monitor service to ensure full service for all customers.
Posted Mar 23, 2024 - 16:38 PDT
Identified
Returns Console customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Mar 23, 2024 - 16:09 PDT
This incident affected: Avalara Returns (Returns Console).