AvaTax for Accounts Payable - Global Imports Service Degradation

Incident Report for Avalara

Resolved

The AvaTax for Accounts Payable service has been fully restored.
Posted Jun 06, 2025 - 14:35 PDT

Monitoring

The response team has addressed the issue impacting AvaTax for Accounts Payable - Global Imports component and continues to monitor service to ensure the return of full service for all customers.
Posted Jun 06, 2025 - 14:28 PDT

Identified

AvaTax for Accounts Payable - Global Imports component may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Jun 06, 2025 - 13:06 PDT
This incident affected: Avalara AvaTax (AvaTax UI).