Avalara Business Licenses Service Outage

Incident Report for Avalara

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 16:07 PDT

Investigating

Avalara Business Licenses customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jun 05, 2025 - 15:19 PDT
This incident affected: Avalara Business Licenses (Avalara License Management, Avalara License Guidance, File Assist Questionnaire).