Avalara AvaTax Service Degradation

Incident Report for Avalara

Resolved

The Avalara AvaTax service has been fully restored.
Posted Jul 23, 2025 - 15:03 PDT

Identified

Avalara AvaTax customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Jul 23, 2025 - 13:44 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service).