Avalara Returns Console Service Degradation

Incident Report for Avalara

Resolved

This incident has been resolved.
Posted May 14, 2025 - 09:09 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 09:04 PDT

Investigating

Avalara Returns Console customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted May 14, 2025 - 08:57 PDT
This incident affected: Avalara Returns (Returns Console).