Avalara VAT Reporting (Cloud) Service Degredation

Incident Report for Avalara

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 03:37 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 03:32 PDT

Investigating

Avalara VAT Reporting (Cloud) customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Mar 31, 2025 - 03:28 PDT
This incident affected: Avalara VAT Reporting (Cloud).