Avalara AvaTax UI Service Degradation
Incident Report for Avalara
Resolved
The Avalara AvaTax UI service has been fully restored.
Posted Jan 03, 2024 - 17:52 PST
Investigating
Avalara AvaTax UI customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jan 03, 2024 - 16:18 PST
This incident affected: Avalara AvaTax (AvaTax UI).