Avalara AvaTax Service Degradation
Incident Report for Avalara
Resolved
The Avalara AvaTax service has been fully restored.
Posted Feb 27, 2024 - 14:35 PST
Monitoring
The response team has addressed the issue impacting Avalara AvaTax and continues to monitor service to ensure full service for all customers.
Posted Feb 27, 2024 - 14:25 PST
Identified
response team has addressed the issue impacting Avalara AvaTax and continues to monitor service to ensure full service for all customers.
Posted Feb 27, 2024 - 14:25 PST
Investigating
Avalara AvaTax customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Feb 27, 2024 - 14:22 PST
This incident affected: Avalara AvaTax (Tax Calculation Service).