Avalara MylodgeTax Service Degradation

Incident Report for Avalara

Resolved

The Avalara MyLodge service has been fully restored.
Posted Feb 20, 2025 - 09:50 PST

Monitoring

The response team has addressed the issue impacting Avalara MyLodge and continues to monitor service to ensure the return of full service for all customers.
Posted Feb 20, 2025 - 09:47 PST

Identified

Avalara MyLodge customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Feb 20, 2025 - 09:03 PST

Investigating

Avalara Mylodge customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Feb 20, 2025 - 08:07 PST
This incident affected: Avalara MyLodgeTax and Avalara MyLodgeTax Pro.