AvaTax Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 08:02 PST
Identified
AvaTax customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Feb 24, 2020 - 06:23 PST
Investigating
AvaTax customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Feb 24, 2020 - 06:20 PST
This incident affected: Avalara AvaTax (Tax Calculation Service).