Intermittent difficulty reaching the support line.
Incident Report for Avalara
Resolved
The issue has been resolved
Posted 3 months ago. Mar 13, 2018 - 11:17 PDT
Investigating
Some callers may experience intermittent difficulty reaching the support line. The issue is currently under investigation
Posted 3 months ago. Mar 13, 2018 - 08:21 PDT
This incident affected: Avalara Toll-Free Phone Numbers (Avalara Enterprise Support Number).