Avalara TrustFile Service Degradation
Incident Report for Avalara
Resolved
The Avalara TrustFile service has been fully restored.
Posted about 1 month ago. Sep 05, 2019 - 11:20 PDT
Monitoring
The response team has addressed the issue impacting Avalara TrustFile and continues to monitor service to ensure full service for all customers.
Posted about 1 month ago. Sep 05, 2019 - 10:53 PDT
Identified
Avalara TrustFile customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted about 1 month ago. Sep 05, 2019 - 10:34 PDT
Investigating
Avalara TrustFile customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted about 1 month ago. Sep 05, 2019 - 10:18 PDT
This incident affected: Avalara TrustFile.