Avalara Account Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Jun 06, 2022 - 15:27 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2022 - 14:55 PDT
Investigating
Avalara Account customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jun 06, 2022 - 14:26 PDT
This incident affected: Avalara Account.