AvaTax Service Degradation
Incident Report for Avalara
Resolved
The AvaTax service has been fully restored.
Posted Mar 20, 2020 - 11:34 PDT
Investigating
AvaTax customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Mar 20, 2020 - 11:30 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service).