Registrations Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 03:39 PDT
Investigating
Registrations service customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jun 17, 2022 - 03:22 PDT