Avalara TrustFile Service Degradation
Incident Report for Avalara
Resolved
The Avalara TrustFile service has been fully restored.
Posted Jan 04, 2022 - 11:46 PST
Monitoring
The response team has addressed the issue impacting Avalara TrustFile and continues to monitor service to ensure full service for all customers.
Posted Jan 04, 2022 - 11:05 PST
Identified
Avalara TrustFile customers in Florida, Wisconsin, and New Jersey may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Jan 04, 2022 - 10:58 PST
Investigating
Avalara TrustFile customers in Florida, Wisconsin, and New Jersey are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jan 04, 2022 - 10:47 PST
This incident affected: Avalara TrustFile.