AvaTax Returns Service Degraded Service
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 16:13 PDT
Investigating
AvaTax Returns Services customers may be experiencing degraded service. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Oct 27, 2021 - 15:53 PDT
This incident affected: Avalara Returns (Returns Services).