AvaTax Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 15:07 PDT
Investigating
AvaTax customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Apr 29, 2021 - 14:58 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service).