Avalara Returns Service Disruption
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 10, 2017 - 23:36 PDT
Identified
We've identified the issue and we're working on a fix. We'll provide an update as soon as the problem is fixed.
Posted 4 months ago. Jul 10, 2017 - 22:32 PDT
This incident affected: Avalara Returns.