Avalara AvaTax Service Degradation
Incident Report for Avalara
Resolved
The Avalara AvaTax service has been fully restored.
Posted Jun 07, 2024 - 23:25 PDT
Monitoring
The response team has addressed the issue impacting Avalara AvaTax Service and continues to monitor service to ensure the return of full service for all customers.
Posted Jun 07, 2024 - 22:27 PDT
Identified
Avalara AvaTax customers may be experiencing degraded service levels. The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Jun 07, 2024 - 22:26 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service, Batch Processing Service).