Avalara Returns Services Service Degradation
Incident Report for Avalara
Resolved
The Avalara Returns Services service has been fully restored.
Posted Jun 08, 2022 - 16:05 PDT
Monitoring
The response team has addressed the issue impacting Avalara Returns Services and continues to monitor service to ensure full service for all customers.
Posted Jun 08, 2022 - 16:01 PDT
Investigating
Avalara Returns Services customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Jun 08, 2022 - 15:36 PDT
This incident affected: Avalara Returns (Returns Services).