buy.avalara.com- Service Degradation
Incident Report for Avalara
Resolved
buy.avalara.com service has been fully restored.
Posted Nov 21, 2019 - 17:16 PST
Investigating
buy.avalara.com customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Nov 21, 2019 - 16:05 PST
This incident affected: Avalara Buy.