Account Usage Report Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 06:56 PST
Investigating
Customers accessing the Account Usage Report may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Nov 20, 2023 - 06:34 PST
This incident affected: Avalara Account.