Support Phone Line Issues
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 02, 2018 - 08:09 PST
Identified
We are currently experiencing technical difficulties. Some customers may encounter problems when calling our support line.
Posted 4 months ago. Mar 02, 2018 - 07:13 PST