Avalara MyLodgeTax Pro Service Degradation
Incident Report for Avalara
Resolved
The Avalara MyLodgeTax Pro service has been fully restored.
Posted Oct 18, 2023 - 16:04 PDT
Monitoring
The response team has addressed the issue impacting Avalara MyLodgeTax Pro and continues to monitor service to ensure full service for all customers.
Posted Oct 18, 2023 - 15:55 PDT
Investigating
Avalara MyLodgeTax Pro customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Oct 18, 2023 - 15:41 PDT
This incident affected: Avalara MyLodgeTax Pro.