Avalara Business Licenses

Incident Report for Avalara

Resolved

The Avalara Business Licenses service has been fully restored.
Posted Nov 18, 2025 - 10:06 PST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 06:49 PST

Monitoring

The response team has addressed the issue impacting Avalara Business Licenses and continues to monitor service to ensure the return of full service for all customers.
Posted Nov 18, 2025 - 06:46 PST

Update

Avalara Business Licenses customers may be experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Nov 18, 2025 - 05:27 PST

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 05:17 PST
This incident affected: Avalara Business Licenses (Avalara License Management, Avalara License Guidance, File Assist Questionnaire, Filing Assist Manager, Business Licenses Customer & Partner Sales & Support Portal, Main License Repository (MLR) API, NRL MCP Server).