Avatax UI Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Sep 09, 2021 - 12:14 PDT
Update
We are continuing to investigate this issue.
Posted Sep 09, 2021 - 11:03 PDT
Investigating
We are currently investigating this issue.
Posted Sep 09, 2021 - 10:06 PDT
This incident affected: Avalara AvaTax (AvaTax UI).