Avalara Account Service Degradation
Incident Report for Avalara
Resolved
The Avalara Account service has been fully restored.
Posted May 04, 2020 - 09:58 PDT
Monitoring
The response team has addressed the issue impacting Avalara Account and continues to monitor service to ensure full service for all customers.
Posted May 04, 2020 - 09:46 PDT
Investigating
Avalara Account customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted May 04, 2020 - 09:37 PDT
This incident affected: Avalara Account.