Avalara AvaTax - Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 13:33 PST
Identified
AvaTax customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Nov 16, 2020 - 13:27 PST
This incident affected: Avalara AvaTax (Tax Calculation Service).