Avalara Toll-Free Numbers - Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 07:01 PST
Monitoring
The response team is beginning to restore service and continues to monitor progress to ensure the return of full service for all customers.
Posted Jan 22, 2025 - 13:56 PST
Identified
Avalara's telecom provider is experiencing a major service outage. Inbound calling to all Avalara numbers is down.

The response team has identified the issue and is urgently working on a resolution. This page will be kept up to date with new information.
Posted Jan 22, 2025 - 13:01 PST
This incident affected: Avalara Toll-Free Phone Numbers (Avalara Main Number, Avalara Enterprise Support Number, MyLodge Support Number).