Avalara Avatax Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 07:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2023 - 07:38 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2023 - 07:16 PDT
Investigating
Avalara Avatax customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Apr 25, 2023 - 07:06 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service).