Avalara Avatax Service Degradation
Incident Report for Avalara
Resolved
This incident has been resolved.
Posted Sep 22, 2020 - 09:35 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2020 - 09:29 PDT
Investigating
Avalara Avatax customers are experiencing degraded service levels. A response team is actively investigating the issue. This page will be kept up to date with new information.
Posted Sep 22, 2020 - 09:25 PDT
This incident affected: Avalara AvaTax (Tax Calculation Service).